目前日期文章:201006 (8)

瀏覽方式: 標題列表 簡短摘要

1.安裝防火牆(Firestarter)有圖形介面的防火牆,設定簡單與快速
$sudo apt-get update
$sudo apt-get install Firestarter

2.開啟圖形介面防火牆設定
[系統]->[管理]->[Firestarter]->精靈設定模式:直接點NEXT

Ubuntu002.JPG 

蒼穹 發表在 痞客邦 留言(0) 人氣()

1.[系統]->[偏好設定]->[遠端桌面]

Ubuntu001.JPG

蒼穹 發表在 痞客邦 留言(0) 人氣()

安裝 X 窗口系統
sudo apt-get -y install x-window-system-core
安裝登錄管理器
sudo apt-get -y install gdm
安裝桌面環境
sudo apt-get -y --force-yes install ubuntu-desktop

出處:
http://forum.icst.org.tw/phpbb/viewtopic.php?f=16&t=14944

蒼穹 發表在 痞客邦 留言(0) 人氣()

安裝openwebmail的錯誤訊息
Can't locate Crypt/Eksblowfish/Bcrypt.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/lib/cgi-bin/openwebmail) at /usr/lib/cgi-bin/openwebmail/auth/auth_unix.pl line 15.
BEGIN failed--compilation aborted at /usr/lib/cgi-bin/openwebmail/auth/auth_unix.pl line 15.

For help, please send mail to the webmaster (webmaster@xxx.com.tw), giving this error message and the time and date of the error.
Software error:

[Tue Jul 15 17:27:36 2008] openwebmail.pl: Can't locate Crypt/Eksblowfish/Bcrypt.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/lib/cgi-bin/openwebmail) at /usr/lib/cgi-bin/openwebmail/auth/auth_unix.pl line 15.
[Tue Jul 15 17:27:36 2008] openwebmail.pl: BEGIN failed--compilation aborted at /usr/lib/cgi-bin/openwebmail/auth/auth_unix.pl line 15.
Compilation failed in require at /usr/lib/cgi-bin/openwebmail/modules/tool.pl line 90.

蒼穹 發表在 痞客邦 留言(0) 人氣()

adonis@ubuntu10:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libdbd-mysql-perl: Depends: perl (>= 5.10.1-12) but 5.10.1-8ubuntu2 is installed
                     Depends: libdbi-perl (>= 1.610.90) but 1.50-1 is installed
                     Depends: perl-dbdabi-94 but it is not installable
  libdbi-perl: Depends: perlapi-5.8.4 but it is not installable
               Depends: libplrpc-perl but it is not installed
  openwebmail: Depends: perl-suid but it is not installed
               Depends: libnet-ldap-perl but it is not installed
               Depends: libpgperl but it is not installable or
                        libpg-perl but it is not installed
               Depends: wwwconfig-common but it is not installed
               Recommends: spamassassin but it is not installed
               Recommends: clamav but it is not installed
E: Unmet dependencies. Try using -f.

蒼穹 發表在 痞客邦 留言(0) 人氣()

$ sudo vim /etc/network/interfaces
up route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.2.1

蒼穹 發表在 痞客邦 留言(0) 人氣()

$sudo vim /etc/apache2/apache2.conf
加入
ServerName 127.0.0.1

重新啟動.....OK

蒼穹 發表在 痞客邦 留言(0) 人氣()

當mail服務器架設好了之後,往往很容易被當成廣告信Server來寄信,利用SMTP Auth認證方式,只有透過帳號密碼認證過的User才能寄信

1.安裝SASL套件
$sudo apt-get install sasl2-bin

2.新增並編輯此檔
$sudo vim /etc/postfix/sasl/smtpd.conf
log_level: 3
pwcheck_method: saslauthd
mech_list: plain login

蒼穹 發表在 痞客邦 留言(0) 人氣()